码迷,mamicode.com
首页 > 其他好文 > 详细

bzoj 1022

时间:2014-12-18 06:46:58      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   ar   io   os   sp   for   on   

1022: [SHOI2008]小约翰的游戏John

Time Limit: 1 Sec  Memory Limit: 162 MB
Submit: 1312  Solved: 820
[Submit][Status]

Description

小约翰经常和他的哥哥玩一个非常有趣的游戏:桌子上有n堆石子,小约翰和他的哥哥轮流取石子,每个人取的时候,可以随意选择一堆石子,在这堆石子中取走任意多的石子,但不能一粒石子也不取,我们规定取到最后一粒石子的人算输。小约翰相当固执,他坚持认为先取的人有很大的优势,所以他总是先取石子,而他的哥哥就聪明多了,他从来没有在游戏中犯过错误。小约翰一怒之前请你来做他的参谋。自然,你应该先写一个程序,预测一下谁将获得游戏的胜利。

Input

本题的输入由多组数据组成,第一行包括一个整数T,表示输入总共有T组数据(T≤500)。每组数据的第一行包括一个整数N(N≤50),表示共有N堆石子,接下来有N个不超过5000的整数,分别表示每堆石子的数目。

Output

每组数据的输出占一行,每行输出一个单词。如果约翰能赢得比赛,则输出“John”,否则输出“Brother”,请注意单词的大小写。

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother

HINT

 

【数据规模】

对于40%的数据,T ≤ 250。

对于100%的数据,T ≤ 500。

 

Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<set>
#include<vector>
using namespace std;
int t,n,ans,a;
int main()
{
      scanf("%d",&t);
      while(t--)
      {
            ans=0;
            scanf("%d",&n);
            bool flag=true;
            for(int i=1;i<=n;i++)
            {
                  scanf("%d",&a);
                  ans^=a;
                  if(a!=1)
                     flag=false;
            }
            if(flag) printf("%s\n",ans?"Brother":"John");
            else printf("%s\n",ans?"John":"Brother");
      }
      return 0;
}

  

bzoj 1022

标签:des   blog   http   ar   io   os   sp   for   on   

原文地址:http://www.cnblogs.com/a972290869/p/4170868.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!