码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2140 Herd Sums

时间:2014-12-18 17:07:08      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:poj   zoj   c++   算法   编程   

Herd Sums
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16120   Accepted: 9541

Description

The cows in farmer John‘s herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N. 

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5. 

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10. 

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem. 

Input

* Line 1: A single integer: N 

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N. 

Sample Input

15

Sample Output

4

题意:求一个数n可以有几种有连续的数字相加得到

解题思路:i*a+i*(i-1)/2=n,转换为a=(n-i*(i-1)/2)/i   把i从1到n遍历一遍,如果(n-i*(i-1)/2)可以整除i那么i符合

#include <iostream>
using namespace std;
int main(){
	int n;
	while (cin>>n){
		int count=0;
		for (int i=1;i<=n;i++){
			int ans=n-i*(i-1)/2;
			if (ans<=0)
				continue;
			if (ans%i==0){
				count++;
			}
		}
		cout<<count<<endl;
	}
	return 0;
}



poj 2140 Herd Sums

标签:poj   zoj   c++   算法   编程   

原文地址:http://blog.csdn.net/codeforcer/article/details/42005649

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!