码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3853——LOOPS

时间:2014-12-18 22:22:49      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:dp

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 2707    Accepted Submission(s): 1119


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
bubuko.com,布布扣

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
6.000
 

Source
 

Recommend
chenyongfu   |   We have carefully selected several similar problems for you:  3857 3854 3849 3850 3851 
 

概率dp,设dp[i][j]表示在点(i, j)时,走出迷宫花费魔力值的期望;


#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 1010;
double dp[N][N];
int r, c;
struct node
{
	double p1, p2, p3;
}mat[N][N];

double dfs(int x, int y)
{
	if (dp[x][y] != -1)
	{
		return dp[x][y];
	}
	double ans = 0;
	if (x < r)
	{
		ans += (dfs(x + 1, y) + 2) * mat[x][y].p3;
	}
	if (y < c)
	{
		ans += (dfs(x, y + 1) + 2) * mat[x][y].p2;
	}
	ans += 2 * mat[x][y].p1;
	if (mat[x][y].p1 == 1)
	{
		dp[x][y] = 0;
	}
	else
	{
		ans /= (1 - mat[x][y].p1);
		dp[x][y] = ans;
	}
	return dp[x][y];
}

int main()
{
	while (~scanf("%d%d", &r, &c))
	{
		for (int i = 1; i <= r; ++i)
		{
			for (int j = 1; j <= c; ++j)
			{
				dp[i][j] = -1;
				scanf("%lf%lf%lf", &mat[i][j].p1, &mat[i][j].p2, &mat[i][j].p3);
			}
		}
		dp[r][c] = 0;
		dfs(1, 1);
		printf("%.3f\n", dp[1][1]);
	}
	return 0;
}


hdu3853——LOOPS

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/42011355

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!