码迷,mamicode.com
首页 > 其他好文 > 详细

E - Puzzle( UVA-227)

时间:2014-12-19 01:49:46      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   ar   io   color   os   sp   

 

 

 Puzzle 

A children‘s puzzle that was popular 30 years ago consisted of a 5x5 frame which contained 24 small squares of equal size. A unique letter of the alphabet was printed on each small square. Since there were only 24 squares within the frame, the frame also contained an empty position which was the same size as a small square. A square could be moved into that empty position if it were immediately to the right, to the left, above, or below the empty position. The object of the puzzle was to slide squares into the empty position so that the frame displayed the letters in alphabetical order.

 

The illustration below represents a puzzle in its original configuration and in its configuration after the following sequence of 6 moves:

1)The square above the empty position moves.

2) The square to the right of the empty position moves.

3) The square to the right of the empty position moves.

4) The square below the empty position moves.

5) The square below the empty position moves.

6) The square to the left of the empty position moves.

 

 

bubuko.com,布布扣

Write a program to display resulting frames given their initial configurations and sequences of moves.

 

Input

Input for your program consists of several puzzles. Each is described by its initial configuration and the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting configuration. Subsequent lines give the sequence of moves.

 

The first line of the frame display corresponds to the top line of squares in the puzzle. The other lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.

 

The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square moves into the empty position. A denotes that the square above the empty position moves; B denotes that the square below the empty position moves; L denotes that the square to the left of the empty position moves; R denotes that the square to the right of the empty position moves. It is possible that there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.

 

Output

Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final configuration should be displayed.

 

Format each line for a final configuration so that there is a single blank character between two adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior position, then it will appear as a sequence of 3 blanks - one to separate it from the square to the left, one for the empty position itself, and one to separate it from the square to the right.

 

Separate output from different puzzle records by one blank line.

 

 

Note: The first record of the sample input corresponds to the puzzle illustrated above.

 

Sample Input

 

TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAAAABBRRRLL0
Z

 

Sample Output

 

Puzzle #1:
T R G S J
X O K L I
M D V B N
W P   A E
U Q H C F

Puzzle #2:
  A B C D
F G H I E
K L M N J
P Q R S O
T U V W X

Puzzle #3:
This puzzle has no final configuration.


这题其实没什么技术含量,只要按照要求一步步顺下来就能搞出来,不过还是要注意细节,像是“每两个输出之间”有一个空行(又因为这个WA了一次= =),还有注意牵扯到字符的输入时一定要仔细想想空格换行这些时不时会拌你一脚的字符(因为这个WA了好几次= =sad)。还有一定要理解清题意,这题要求只输入一个字符Z时终止程序,不要理解成第一个字符为Z时就终止程序。注意一下细节,A掉这题应该就会很容易。最重要的是,当你实在是找不出错误的时候,一定要自己去调试,不要依靠别人来给你找错,这样你的水平是不会有多大提高的。好了,废话不多说,贴一下代码(水平太低,只能写出这么长的代码来= =)


#include <stdio.h>
#include <string.h>

int main()
{
    char puzzle[6][6],move[1000],temp;
    int i,j,k,si,sj,flag,count=0;
    while(gets(puzzle[0])!=NULL&&strcmp(puzzle[0],"Z")!=0)
    {
        count++;
        flag=1;
        for(i=1; i<5; i++)
        {
            gets(puzzle[i]);
        }

        for(i=0;i<5;i++)
        {
            for(j=0;j<5;j++)
            {
                if(puzzle[i][j]== )
                {
                    si=i;sj=j;break;
                }
            }
        }
        for(i=0;; i++)
        {
            scanf("%c",&move[i]);
            if(move[i]==0)
                break;
        }
        k=i;
        for(i=0; i<k; i++)
        {
            switch(move[i])
            {
            case A :
                if(si-1<0)
                {
                    flag=0;
                }
                else
                {
                    temp=puzzle[si][sj];
                    puzzle[si][sj]=puzzle[si-1][sj];
                    puzzle[si-1][sj]=temp;
                    si=(si-1);
                }
                break;
            case B :
                if(si+1>4)
                {
                    flag=0;
                }
                else
                {
                    temp=puzzle[si][sj];
                    puzzle[si][sj]=puzzle[si+1][sj];
                    puzzle[si+1][sj]=temp;
                    si=(si+1);
                }
                break;
            case L :
                if(sj-1<0)
                {
                    flag=0;
                }
                else
                {
                    temp=puzzle[si][sj];
                    puzzle[si][sj]=puzzle[si][sj-1];
                    puzzle[si][sj-1]=temp;
                    sj=(sj-1);
                }
                break;
            case R :
                if(sj+1>4)
                {
                    flag=0;
                }
                else
                {
                    temp=puzzle[si][sj];
                    puzzle[si][sj]=puzzle[si][sj+1];
                    puzzle[si][sj+1]=temp;
                    sj=(sj+1);
                }
            }
            if(flag==0) break;
        }
        if(count!=1)
            printf("\n");
        printf("Puzzle #%d:\n",count);
        if(flag==0)
            printf("This puzzle has no final configuration.\n");
        else
        {
            for(i=0; i<5; i++)
                for(j=0; j<5; j++)
                {
                    if(j==4)
                        printf("%c\n",puzzle[i][j]);
                    else
                    {
                        printf("%c ",puzzle[i][j]);
                    }
                }
        }
        getchar();
    }
    return 0;
}

 

E - Puzzle( UVA-227)

标签:des   style   blog   http   ar   io   color   os   sp   

原文地址:http://www.cnblogs.com/Highmath/p/4173016.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!