码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2524 Ubiquitous Religions

时间:2014-12-19 22:10:23      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:poj   zoj   c++   算法   编程   

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 25316   Accepted: 12489

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题意:在一个大学里面有的学生信仰多少个不同的宗教,注意一点就是下面没出现的学生,视为他们各自信仰不同的宗教

并查集模板:

int father[MAX],rank[MAX];
void init(int n){
	for (int i=1;i<=n;i++){
		father[i]=i;
		rank[i]=1;
	}
}
int find(int x){
	if (x!=father[x])
		father[x] = find(father[x]);	//路径压缩
	return father[x];
}
void Union(int x,int y){
	int i=find(x);
	int j=find(y);
	if (i==j)
		return;
	if (rank[i]<rank[j])
		father[i]=j;
	else{
		father[j]=i;
		if (rank[i]==rank[j])	//两棵树同高
			rank[i]++;
	}
}
bool same(int x,int y){
        return find(x)==find(y);
}

本题代码:

#include <iostream>
#include <stdio.h>
using namespace std;
int father[50000+1],rank[50000+1];
void init(int n){
	for (int i=1;i<=n;i++){
		father[i]=i;
		rank[i]=1;
	}
}
int find(int x){
	if (x!=father[x])
		father[x] = find(father[x]);	//路径压缩
	return father[x];
}
void Union(int x,int y){
	int i=find(x);
	int j=find(y);
	if (i==j)
		return;
	if (rank[i]<rank[j])
		father[i]=j;
	else{
		father[j]=i;
		if (rank[i]==rank[j])	//两棵树同高
			rank[i]++;
	}
}
int main(){
	int n,m,x,y,num=1;
	while (cin>>n>>m){
		if (n==0&&m==0)
			break;
		init(n);
		for (int i=0;i<m;i++){
			cin>>x>>y;
			Union(x,y);
		}
		int ans=0;
		for (int i=1;i<=n;i++){
			if (i==father[i])
				ans++;
		}
		cout<<"Case "<<num<<": "<<ans<<endl;
		num++;
	}
	return 0;
}



poj 2524 Ubiquitous Religions

标签:poj   zoj   c++   算法   编程   

原文地址:http://blog.csdn.net/codeforcer/article/details/42031467

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!