码迷,mamicode.com
首页 > 其他好文 > 详细

I - All in All

时间:2014-12-19 23:22:54      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No




哭瞎。。看起来这么简单的一道题。。。暗藏了好多坑。。(不过应该还是我技术太差。。)首先,题目里没有给字符串的数据范围,因为这个RE了两次(〒_〒),以后做这种没给范围的题一定要把数组往大开。其次就是自己在考虑问题的时候想得太简单,只是单纯的样例对了就提交,没有深入思考其他一些特殊的情况,因为这个WA了两次(〒_〒)(ps:估计自己的算法太差,,所以才需要考虑很多种情况)。



#include <stdio.h>
#include <string.h>

char str1[1000000],str2[1000000];
int main()
{
    int i,j,flag;
    while(~scanf("%s %s",str1,str2))
    {
        j=0;
        flag=0;
        for(i=0;i<strlen(str1);i++)
        {
            for(;j<strlen(str2);j++)
            {
                if(str1[i]==str2[j])
                {
                    if(i==strlen(str1)-1)
                        flag=1;
                    break;
                }
            }
            j++;
        }
        if(flag==1) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

 

I - All in All

标签:

原文地址:http://www.cnblogs.com/Highmath/p/4174819.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!