码迷,mamicode.com
首页 > 其他好文 > 详细

03-3. Tree Traversals Again (25)

时间:2014-12-20 14:19:10      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

03-3. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

技术分享
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 

提交代码

简单的模拟





#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
#define lson ((root<<1))
#define rson ((root<<1)+1)
#define MID ((l+r)>>1)
typedef long long ll;
typedef pair<int,int> P;
#define For(i,t,n) for(int i=(t);i<(n);i++)
const int maxn=20001;
const int base=1000;
const int inf=9999999;
const double eps=1e-5;
int T[maxn];
int f[maxn];
int n;
int first=1;
void post(int root)
{
    if(T[lson]!=-1)
        post(lson);
    if(T[rson]!=-1)
        post(rson);
    if(first)
    {
        first=0;
        printf("%d",T[root]);
    }
    else
        printf(" %d",T[root]);
}
int main()
{
    int m,i,j,k,t;
    cin>>n;
    memset(T,-1,sizeof(T));
    //memset(f,0,sizeof(f));
    n*=2;
    string a;
    stack<int> s;
    int root=1;
    cin>>a>>t;
    T[1]=t;
    s.push(t);
    int ok=1;
    for(i=1; i<n; i++)
    {
        cin>>a;
        if(a=="Push")cin>>t;
        if(a=="Push")
        {
            s.push(t);
            if(ok)
            {
                T[lson]=t;
                root=lson;
            }
            else
            {
                T[rson]=t;
                root=rson;
                ok=1;
            }
        }
        else if(a=="Pop")
        {
            int tmp=s.top();
            for(j=0;j<maxn;j++)
                if(T[j]==tmp)break;
            root=j;
            s.pop();
            ok=0;
        }
    }


    post(1);
    printf("\n");
    return 0;
}


















03-3. Tree Traversals Again (25)

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/42041997

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!