码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3071---Football

时间:2014-12-20 16:59:10      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:dp

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3267   Accepted: 1668

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 ? pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

Stanford Local 2006

概率dp+规律,
令dp[i][j] 表示 第i个人赢到第j轮的概率
然后找到所有可能在第j轮和i相遇的队员(化二进制,找最高位不同)

/*************************************************************************
    > File Name: POJ3071.cpp
    > Author: ALex
    > Mail: 405045132@qq.com
    > Created Time: 2014年12月20日 星期六 13时20分58秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const int N = 200;
double dp[N][10];
double mat[N][N];
int n;

int diff(int a, int b)
{
    for (int i = n; i >= 0; i--)
    {
        if ((a & (1 << i)) != (b & (1 << i)))
        {
            return i;
        }
    }
}

int main()
{
    while (~scanf("%d", &n))
    {
        if (n == -1)
        {
            break;
        }
        for (int i = 1; i <= (1 << n); i++)
        {
            for (int j = 1; j <= (1 << n); j++)
            {
                scanf("%lf", &mat[i][j]);
            }
        }
        for (int i = 1; i <= (1 << n); i++)
        {
            for (int j = 1; j <=n; j++)
            {
                dp[i][j] = 0.0;
            }
        }
        for (int i = 1; i <= (1 << n); i++)
        {
            dp[i][0] = 1.0;
        }
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= (1 << n); j++)
            {
                for (int k = 1; k <= (1 << n); k++)
                {
                    if (j == k)
                    {
                        continue;
                    }
                    int p = diff(j - 1, k - 1);
                    if (p != i - 1)
                    {
                        continue;
                    }
                    dp[j][i] += dp[j][i - 1] * dp[k][i - 1] * mat[j][k];
                }
            }
        }
        int cnt;
        double ans = 0;
        for (int i = 1; i <= (1 << n); i++)
        {
            if (ans < dp[i][n])
            {
                ans = dp[i][n];
                cnt = i;
            }
        }
        printf("%d\n", cnt);
    }
    return 0;
}


POJ3071---Football

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/42042349

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!