码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1019

时间:2014-12-21 17:56:51      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33105    Accepted Submission(s): 12478


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

 

Sample Output
105 10296
 
代码:
#include "stdio.h"
int leastCommon(int a,int b)
{
   if(b==0) return a;
   return leastCommon(b,a%b);
}
int main()
{
    int n,m,t1,t2;
    while(scanf("%d",&n)!=-1)
    {
        while(n--)
        {
            scanf("%d",&m);
            scanf("%d",&t1);
            m--;
            while(m--)
            {
                scanf("%d",&t2);
                t1=t1/leastCommon(t1,t2)*t2;
            }
            printf("%d\n", t1);
        }
     
    }
}

这个需要注意:

t1=t1/leastCommon(t1,t2)*t2;
如果写成
t1=t1*t2/leastCommon(t1,t2);  
就会越界!

HDOJ 1019

标签:

原文地址:http://www.cnblogs.com/tianyong/p/4176813.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!