码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1048 What Is Your Grade? (简单模拟)

时间:2014-05-23 00:59:22      阅读:375      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   c   code   



                                           What Is Your Grade?

Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

Sample Output
100 90 90 95 100
 

Author
lcy
 

源代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 110

using namespace std;

int sum[10];

struct people{
    int pro;   //问题数
    int sco;   //分数
    char time[20];
    int pos;    //原来的位置
}p[maxn];

bool cmp1(people a,people b)
{
    if(a.pro==b.pro)
        return strcmp(b.time,a.time)>0?1:0;            //注意这里,,,让我WA爆了,,,,非0,都是真!!!<img alt="哭" src="http://static.blog.csdn.net/xheditor/xheditor_emot/default/cry.gif" />
    else
        return a.pro>b.pro;
}

bool cmp2(people a,people b)
{
    return a.pos<b.pos;
}


int main()
{
    int t;
    while(scanf("%d",&t),t!=-1)     //数据输入
    {
        memset(sum,0,sizeof sum);
        for(int i=0;i<t;i++)
        {
            scanf("%d%s",&p[i].pro,p[i].time);
            sum[p[i].pro]++;        //计数,一个问题数,,的个数
            p[i].pos=i;
        }

        for(int i=1;i<=4;i++)       //前一半,数
            if(sum[i]!=1)
                sum[i]=sum[i]/2;

        sort(p,p+t,cmp1);           //问题数,大到小,时间少到多

        for(int i=0;i<t;i++)
        {
            if(p[i].pro==5)        //5个
                p[i].sco=100;
            else
            {
                if(p[i].pro==0)    //0个
                    p[i].sco=50;
                else         //1~4个
                {
                    if(sum[p[i].pro]>0)
                    {
                        p[i].sco=p[i].pro*10+55;   //用一个前一半,
                        sum[p[i].pro]--;           //减一个
                    }
                    else
                        p[i].sco=p[i].pro*10+50;
                }
            }
        }
        sort(p,p+t,cmp2);              //按pos位置,复原
        for(int i=0;i<t;i++)
            printf("%d\n",p[i].sco);
        printf("\n");

    }

    return 0;
}


(坑啊。。。。trcmp()函数用错了。。。。。WA爆了)

HDU 1048 What Is Your Grade? (简单模拟),布布扣,bubuko.com

HDU 1048 What Is Your Grade? (简单模拟)

标签:des   style   blog   class   c   code   

原文地址:http://blog.csdn.net/code_or_code/article/details/26514271

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!