码迷,mamicode.com
首页 > 其他好文 > 详细

Ping pong

时间:2014-12-23 21:12:24      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:

 Description

N(3技术分享N技术分享20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee‘s house. For some reason, the contestants can‘t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee‘s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1技术分享T技术分享20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1, a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1技术分享ai技术分享100000 , i = 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1
题意:在一条街上,住着一些乒乓球运动员,他们之间要举行比赛,他们既可以当选手也可以当裁判,要求是:裁判住的位置必须在比赛队员两之间,裁判的能力值也是;

题目抵杭给出数据组数,然后第二行第一个数:是球员的个数,接下来的n个数从最西边到最东边球员的能力值;


<span style="font-size:14px;"># include <cstdio>
# include <cstring>
# include <iostream>
# include <algorithm>
using namespace std;

const int maxn=20000+5;
int n,t,c[maxn],d[maxn],x[100005],a[maxn];

int lowbit(int x)
{
     return x & (-x);
}

int sum(int k)
{
    int ans=0;
    while(k > 0)
    {
        ans+=x[k];
        k-=lowbit(k);
    }
    return ans;
}

void edit(int k)
{
    while(<span style="background-color: rgb(255, 255, 255);"><span style="color:#ff0000;">k<=100000</span></span>)
    {
        x[k]+=1;
        k+=lowbit(k);
    }
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));memset(d,0,sizeof(d));memset(x,0,sizeof(x));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)    scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)    { edit(a[i]);   c[i]=sum(a[i]-1); }
        memset(x,0,sizeof(x));
        for(int i=n;i>=1;i--)    { edit(a[i]);   d[i]=sum(a[i]-1); }
        long long ans=0;
        for(int i=2;i<n;i++)
            ans+=(long long)c[i]*(n-i-d[i])+(long long)d[i]*(i-c[i]-1);
        printf("%lld\n",ans);
    }
    return 0;
}
</span>



Ping pong

标签:

原文地址:http://blog.csdn.net/rechard_chen/article/details/42108823

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!