码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1247 Hat’s Words 字典树

时间:2014-12-24 13:32:23      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:c++   数据结构   


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
a ahat hat hatword hziee word
 

Sample Output
ahat hatword 题意:输入一连串的 单词 组成的字典 输出字典中由两个其他单词组成的单词 构造字典树即可。。。 代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node{
    int last;                  //last用来判断是否为一个单词的最后一个字母
    struct node *next[26];
    node()                 //构造函数
    {
        last=0;                    
        memset(next,NULL,sizeof(next));
    }
}*root;
char str[50005][20];
int s=0;
void insert_str(char *s)        //构造字典树
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        if(p->next[d]==NULL)
        {
            p->next[d]= new node();
            p=p->next[d];
        }
        else
            p=p->next[d];
        s++;
    }
    p->last=1;
    return ;
}
int find2(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&*(s+1)=='\0')     //当后半部分为单词 且没有后缀
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;               //重要  返回可能默认为1
}
int find(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&find2(s+1))    //当已经确认前半部分为一个单词 再确认后半部分是否为单词
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;
}
int main()
{
    int i,j;
    root=new node();                 //  根节点
    while(scanf("%s",str[s])!=EOF)
    {
        insert_str(str[s]);
        s++;
    }
    for(i=0;i<s;i++)
    {
        if(find(str[i]))
            cout<<str[i]<<endl;
    }
    return 0;
}




hdu1247 Hat’s Words 字典树

标签:c++   数据结构   

原文地址:http://blog.csdn.net/axuan_k/article/details/42122159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!