码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2399

时间:2014-12-24 18:07:00      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2550    Accepted Submission(s): 1497


Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.

Sample Input
A B C D F B F F C C A D C E F

Sample Output
2.00 1.83 Unknown letter grade in input

Author
2006Rocky Mountain Warmup

Source
 
 
 
 
题目说的很明白,ABCDF分别代表43210。求你叫它们的平均值。注意两点就好,遇到其他字母直接输出Unknown letter grade in input。遇到空格要处理下。上代码
 
 
 
#include <stdio.h>
#include <string.h>
int main()
{
    char a[10005];
    while(gets(a))
    {
        int sum=0;
        int sum1=0;
        int sum2=0;
        int l=strlen(a);
        int i;
        for(i=0;i<l;i++) 
        {
            if(a[i]=='A')
            {
            sum+=4;
            sum1++;
            }
            else if(a[i]=='B')
            {
            sum+=3; sum1++;
            }
            else if(a[i]=='C')
              {
                    sum+=2;  sum1++;
              }
            else if(a[i]=='D')
           {
            sum+=1;     sum1++;
           }
            else if(a[i]=='F')
          {
            sum+=0; sum1++;
          }
          else if(a[i]==' ')  //遇到空格 ,则继续。
          continue;
          else   //  遇到其他字母
          {
            sum2=1;//  格式控制  ,然后跳出
            break;
          }
        }
        if(sum2)
        printf("Unknown letter grade in input\n");//  如果是真,直接输出Unknown letter grade in input
        else
         printf("%.2lf\n",double(sum*1.0/sum1));//  sum2不等于一,直接输出平均值
    }

}

 
 
 
 
 
 
 

HDU 2399

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/42126301

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!