码迷,mamicode.com
首页 > 其他好文 > 详细

zoj3329---One Person Game

时间:2014-12-24 18:14:01      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:dp   zoj   

One Person Game

Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namelyDie1, Die2 and Die3. Die1 hasK1 faces. Die2has K2 faces.Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 toK1, K2, K3is exactly 1 /K1, 1 / K2 and 1 / K3.You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 isa, the up-facing number of Die2 is b and the up-facing number ofDie3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter‘s number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 <T <= 300) indicating the number of test cases.Then T test cases follow. Each test case is a line contains 7 non-negative integersn, K1, K2, K3,a, b, c(0 <= n <= 500, 1 < K1,K2, K3 <= 6, 1 <= a <= K1, 1 <=b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

Author: CAO, Peng

Source: The 7th Zhejiang Provincial Collegiate Programming Contest


概率dp, 方程很好推, dp[i] 表示cnt = i时,达到目标状态的期望值

dp[i] = sigma(pk * dp[i+k]) + p0 * dp[0] + 1;

然后我就没想法了,因为涉及了dp[0], 然后参考了kuangbin博客才知道要转换求系数

看来概率dp还是练习的不够


/*************************************************************************
    > File Name: zoj3329.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2014年12月24日 星期三 16时06分54秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

double A[510], B[510];
int k1, k2, k3;
int a, b, c, n;

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		double p0;
		scanf("%d%d%d%d%d%d%d", &n, &k1, &k2, &k3, &a, &b, &c);
		memset (A, 0, sizeof(A));
		memset (B, 0, sizeof(B));
		p0 = (double)(1.0 / k1 / k2 / k3);
		for (int i = n; i >= 0; --i)
		{
			A[i] = p0;
			B[i] = 1;
			for (int j = 1; j <= k1; ++j)
			{
				for (int k = 1; k <= k2; ++k)
				{
					for (int l = 1; l <= k3; ++l)
					{
						if (j == a && k == b && l == c)
						{
							continue;
						}
						A[i] += p0 * A[i + j + k + l];
						B[i] += p0 * B[i + j + k + l];
					}
				}
			}
		}
		printf("%.15f\n", B[0] / (1 - A[0]));
	}
	return 0;
}


zoj3329---One Person Game

标签:dp   zoj   

原文地址:http://blog.csdn.net/guard_mine/article/details/42125391

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!