码迷,mamicode.com
首页 > 其他好文 > 详细

Ping pong

时间:2014-12-24 22:50:18      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:uva   树状数组   

 Ping pong

Description

技术分享

N(3技术分享N技术分享20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee‘s house. For some reason, the contestants can‘t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee‘s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1技术分享T技术分享20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1技术分享ai技术分享100000 , i = 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1


思路:  采用前缀和,后缀和得到结果
        再求前缀和,后缀和的时候后用树状数组算法得出来。
       
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
int max(int a,int b) {return a>b?a:b;}
inline int lowbit(int x)
{
  return x&(-x);//2^k
}
struct Fen
{
  int n;
  vector<int> c;

  void resize(int n) {this->n=n;c.resize(n);}
  void clear() {fill(c.begin(),c.end(),0);}
  int sum(int x) //求前 N项的和  
  {
    int r=0;
	while(x>0)
	{
	 r+=c[x];
	 x-=lowbit(x);
	}
	return r;
  }
  void add(int x,int d)//求前 N项sum的和  
  {
    while(x<=n)
	{
	  c[x]+=d;x+=lowbit(x);
	}
  }
};

int n,a[20005],c[20005],d[20005];
Fen f;

int main()
{
  int t,i;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    memset(d,0,sizeof(d));
    int maxs=0;
	for(i=1;i<=n;i++)
	{
	  scanf("%d",&a[i]);
	  maxs=max(maxs,a[i]);
	}
	f.resize(maxs+1);
	f.clear();

	for(i=1;i<=n;i++)//前缀和 
	{
	  f.add(a[i],1);//求前 N项sum的和  
	  c[i]=f.sum(a[i]-1);//求前 N项的和  
	}
	f.clear();
	for(i=n;i>=1;i--)//后缀和 
	{
	  f.add(a[i],1);
	  d[i]=f.sum(a[i]-1);
	}
	long long ans=0;
	for(i=2;i<n;i++)
		ans+=(long long)c[i]*(n-i-d[i])+(long long)d[i]*(i-1-c[i]);
	printf("%lld\n",ans);
  }
  return 0;
}

Ping pong

标签:uva   树状数组   

原文地址:http://blog.csdn.net/u012346225/article/details/42128255

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!