码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 409-Excuses, Excuses!(模拟)

时间:2014-12-28 14:17:40      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Excuses, Excuses!
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享


 Excuses, Excuses! 

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number ( 技术分享 ) defines the number of keywords to be used in the search. The second number ( 技术分享 ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • Lines K+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( 技术分享 ) and will occupy columns 1 through L in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

题意:给两个数m,n。即m个关键字,n句借口,哪个借口包含的的关键字最多,就输出当前的借口


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
using namespace std;
char key[20][20];
char ex[20][110];
int cnt[110];
int n,m;
int find(char *str)
{
    char a[110];
    int i,j=0;
    int count = 0;
    for(i=0;str[i]!='\0';i++)
    {
        if(str[i]>='A'&&str[i]<='Z'||str[i]>='a'&&str[i]<='z')//关键字都是小写,所以把借口里面的大写字母全部转换成小写字母
        {
            if(str[i]>='A'&&str[i]<='Z')
            {
                a[j]=str[i]+32;
            }
            else
                a[j]=str[i];
            j++;
        }
        else//因为语句中包含其他的字符,所以当是其他字符的时候
        {
            a[j] = '\0';//意味着重新换成另一个单词
            for(j = 0; j < m; j++)
            {
                if(strcmp(a,key[j]) == 0)
                {
                    count++;
                }
            }
            j = 0;//拿出下一个单词;
        }
    }
    return count;
}

int main()
{
    int i;
    int t=1;
    int maxx;
    while(~scanf("%d %d",&m,&n))
    {
        getchar();
        maxx=0;
        memset(cnt,0,sizeof(cnt));
        for(i=0; i<m; i++)
            gets(key[i]);
        for(i=0; i<n; i++)
            gets(ex[i]);
        for(i=0; i<n; i++)
            cnt[i]=find(ex[i]);
        for(i=0; i<n; i++)
            maxx=max(maxx,cnt[i]);
        printf("Excuse Set #%d\n",t++);
        for(i=0; i<n; i++)
        {
            if(maxx==cnt[i])
            {
                puts(ex[i]);
            }
        }
        printf("\n");
    }
    return 0;
}


UVA 409-Excuses, Excuses!(模拟)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/42213029

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!