码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3274 哈希

时间:2014-12-28 22:18:33      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=3274

Description

Farmer John‘s N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K
Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4
题意:对于每头奶牛都有一个"feature ID",用一个整数表示,把这个数表示成K位二进制,对应位为1表示具有相应的特征,这样n头奶牛排成一排,求最长的连续区间,使得里面奶牛的全部K个特征个数达到平衡,即:
如果用sum[i][j] 表示前 i 头奶牛的第 j 个特征个数总和,则对于区间[a + 1, b],有
sum[b][1] - sum[a][1] = sum[b][2] - sum[a][2] = sum[b][j] - sum[a][j]   (1<= j <= K)
对表达式做变换得:
sum[b][1] - sum[b][2] = sum[a][1] - sum[a][2]
sum[b][1] - sum[b][j] = sum[a][1] - sum[a][j]   (1<= j <= K)
如果令c[i][j] = sum[i][j] - sum[i][1] (1<= j <= K)
则条件可以转换为:c[a] == c[b]
这样我们就可以在求的 c[i][j] (1<= i <= N, 1 <= j <= K)的基础上,对数组c[i](1 <= i <= N) hash,用开散列法(拉链法)求解即可。(摘自互联网)
哈希的结果是将哈希值相同的序列再进行比较,从而降低了时间复杂度。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=100005;
const int hashseed=99983;
int n,k;
int sum[maxn][35],c[maxn][35];
int head[hashseed+2],next[maxn];

int hash(int v[])
{
    int h=0;
    for(int i=1; i<=k; i++)
    {
        h=(h<<2)+(v[i]>>4)^(v[i]<<10);
    }
    h=(h+hashseed)%hashseed;
    return h;
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=n; i++)
        {
            int cnt;
            scanf("%d",&cnt);
            for(int j=1; j<=k; j++)
            {
                sum[i][j]=sum[i-1][j]+cnt%2;
                cnt/=2;
            }
        }
        int maxx=0;
        memset(head,-1,sizeof(head));
        for(int i=0; i<=n; i++)///一定要从0开始
        {
            for(int j=1; j<=k; j++)
            {
                c[i][j]=sum[i][j]-sum[i][1];
            }
            int h=hash(c[i]);
            bool flag=0;
            for(int p=head[h]; p!=-1; p=next[p])
            {
                int j;
                for(j=1; j<=k; j++)
                {
                    if(c[i][j]!=c[p][j])
                        break;
                }
                if(j>k)
                {
                    maxx=max(maxx,i-p);
                    flag=1;
                    break;
                }
            }
            if(flag==0)
            {
                next[i]=head[h];
                head[h]=i;
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}



poj 3274 哈希

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/42218731

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!