码迷,mamicode.com
首页 > 其他好文 > 详细

九度OJ 1098 字母统计

时间:2014-12-29 01:21:44      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:九度oj   1098   

题目1098:字母统计

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3187

解决:1536

题目描述:

输入一行字符串,计算其中A-Z大写字母出现的次数

输入:

案例可能有多组,每个案例输入为一行字符串。

输出:

对每个案例按A-Z的顺序输出其中大写字母出现的次数。

样例输入:
DFJEIWFNQLEF0395823048+_+JDLSFJDLSJFKK
样例输出:
A:0
B:0
C:0
D:3
E:2
F:5
G:0
H:0
I:1
J:4
K:2
L:3
M:0
N:1
O:0
P:0
Q:1
R:0
S:2
T:0
U:0
V:0
W:1
X:0
Y:0
Z:0
#include<stdio.h>
#include<ctype.h>
#include<string.h>
char s[10000];
int cnt[26];
int main(int argc, char *argv[])
{
    while(gets(s)!=NULL)
    {
        memset(cnt,0,sizeof(cnt));
        for(int i=0;i<strlen(s);++i)
        {
            if(isalpha(s[i])&&isupper(s[i]))
            {
                cnt[s[i]-'A']++;
            }
        }
        for(int i=0;i<26;++i)
        {
            printf("%c:%d\n",i+'A',cnt[i]);
        }
    }
    return 0;
}
 
/**************************************************************
    Problem: 1098
    User: kirchhoff
    Language: C
    Result: Accepted
    Time:10 ms
    Memory:924 kb
****************************************************************/



九度OJ 1098 字母统计

标签:九度oj   1098   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/42218167

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!