码迷,mamicode.com
首页 > 其他好文 > 详细

【hdu 3037】Saving Beans

时间:2014-12-29 09:05:34      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:oi   hdu   数论   

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2578    Accepted Submission(s): 956


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime. 
 

Output
You should output the answer modulo p.
 

Sample Input
2 1 2 5 2 1 5
 

Sample Output
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
 

Source

lucas定理模板题。


技术分享


ans=c(n,1)+c(n+1,2)+....c(n+m-1,m)


根据c(n+1,m)=c(n,m)+c(n,m-1),ans=c(n+m,m)然后套用Lucas模板


#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#define LL long long
using namespace std;
int T;
LL fac[100005],n,m,p;
LL Powmod(LL a,LL b,LL p)  //费马小定理求逆元
{
	LL ans=1LL,now=a;
	while (b)
	{
		if (b&1) ans=(ans*now)%p;
		b>>=1;
		now=(now*now)%p;
	}
	return ans;
}
LL Lucas(LL n,LL m,LL p)
{
	LL ans=1LL;
	while (n&&m)
	{
		LL a=n%p,b=m%p;
		if (a<b) return 0;
		ans=(ans*fac[a]*Powmod(fac[b]*fac[a-b]%p,p-2,p))%p;
		n/=p;
		m/=p;
	}
	return ans;
}
void Getfact(LL p)
{
	fac[0]=1LL;
	for (int i=1;i<=p;i++)
		fac[i]=(fac[i-1]*(LL)i)%p;
}
int main()
{
    scanf("%d",&T);
    while (T--)
    {
		scanf("%lld%lld%lld",&n,&m,&p);
		Getfact(p);
		printf("%lld\n",Lucas(n+m,m,p));
	}
	return 0;
}

技术分享


感悟:

Lucas定理就是Lucas(n,m,p)=Lucas(n/p,m/p,p)*C(n%p,m%p)


但是证明的最后一句没看懂!!

【hdu 3037】Saving Beans

标签:oi   hdu   数论   

原文地址:http://blog.csdn.net/regina8023/article/details/42217545

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!