码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2056

时间:2014-12-29 09:07:51      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output
1.00 56.25

Author
seeyou

Source

校庆杯Warm Up 



一开始题目看不懂,后来看懂了题目,发现此题巨坑。题意就是给你四个点的坐标x1,y1,x2,y2,x3,y3,x4,y4。然后前两点坐标连线,变成一个矩阵的对角线。后两点一样。求的是矩阵相交的面积。代码如下。带解析。。



#include<stdio.h>
double max(double a,double b)  //求两者中大的
{
	return a>b?a:b;
}
double min(double c,double d)  //求两者中小的
{
	return c<d?c:d;
}
void solve()
{
	double x1,y1,x2,y2,x3,y3,x4,y4,t;
	while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4)!=EOF)
	{
		if(x1>x2)   t=x1,x1=x2,x2=t;// 保证x2>x1。符合图中的情况。
		if(y1>y2)   t=y1,y1=y2,y2=t;//同上
		if(x3>x4)   t=x3,x3=x4,x4=t;//同上
		if(y3>y4)   t=y3,y3=y4,y4=t;//同上
		double l=min(x2,x4)-max(x1,x3);// 求宽
		double d=min(y2,y4)-max(y1,y3);// 求高。
		double s=l*d; //求面积。
		printf("%.2lf\n",max(x1,x3)>min(x2,x4)||max(y1,y3)>min(y2,y4)?0:s);//如果高或宽小于0解为0,即没有相交的部分,否则输出面积
	}
}
int main()
{
	solve();//问题解决。
	return 0;
}


技术分享

HDU 2056

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/42214023

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!