码迷,mamicode.com
首页 > 其他好文 > 详细

poj1200 哈希

时间:2014-12-29 10:28:57      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1200

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5
/**
poj  1200 hash
题目大意:
         给定一个字符串,其中含有不同的字母数量为m,现在求这个字符串中有多少个长度为n且长的互不相同的字符子串
解题思路:
         将所有不同的字母从0~m-1编号,把字符串转化为一个m进制数,作为hash的对应关系。即可以利用O(1)的时间判断。总的时间复杂度为O(n*m)
         根据常识m一定是0~256之间的数,因此时间复杂度还是可以接受的。
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=16000003;
int n,m;
int hash[maxn],num[300];
char a[maxn];
int main()
{
    while(~scanf("%d%d%s",&n,&m,a))
    {
        int len=strlen(a);
        int cnt=0;
        num[a[0]]=cnt++;
        for(int i=1;i<len;i++)
        {
            if(num[a[i]]==0)
                num[a[i]]=cnt++;
        }
        int ans=0;
        for(int i=0;i<=len-n;i++)
        {
            int sum=0;
            for(int j=0;j<n;j++)
            {
                sum=sum*cnt+num[a[i+j]];
            }
            if(!hash[sum])
            {
                ans++;
                hash[sum]=true;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


poj1200 哈希

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/42234693

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!