码迷,mamicode.com
首页 > 其他好文 > 详细

九度OJ—题目1049:字符串去特定字符

时间:2014-12-29 12:06:34      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:九度oj   题目1049   字符串去特定字符   

题目描述:

输入字符串s和字符c,要求去掉s中所有的c字符,并输出结果。

输入:

测试数据有多组,每组输入字符串s和字符c。

输出:

对于每组输入,输出去除c字符后的结果。

样例输入:
heallo
a
样例输出:
hello
来源:
2009年哈尔滨工业大学计算机研究生机试真题
答疑:

解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7773-1-1.html


import java.util.*;
 
public class Main {
 
    public static void test(String str, char c) {
        for (int i = 0; i < str.length(); i++) {
            if (str.charAt(i) != c) {
                System.out.print(str.charAt(i));
            } else
                continue;
        }
    }
 
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        String a;
        String bb;
        while (cin.hasNext()) {
            a = cin.nextLine();
            bb = cin.nextLine();
            char b = bb.charAt(0);
            test(a, b);
            System.out.print("\n");
        }
    }
}
/**************************************************************
    Problem: 1049
    User: vhreal
    Language: Java
    Result: Accepted
    Time:80 ms
    Memory:15416 kb
****************************************************************/


九度OJ—题目1049:字符串去特定字符

标签:九度oj   题目1049   字符串去特定字符   

原文地址:http://blog.csdn.net/wtyvhreal/article/details/42235973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!