码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2886 Who Gets the Most Candies? (线段树单点更新应用)

时间:2014-12-30 23:42:05      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:c++   poj   

                        poj 2886 Who Gets the Most Candies?

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (?A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N≤ 500,000) and K (1 ≤ KN) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3



题目大意:N 个小孩围成一圈,他们被顺时针编号为 1 到 N。每个小孩手中有一个卡片,上面有一个非 0 的数字,游戏从第 K 个小孩开始,他告诉其他小孩他卡片上的数字并离开这个圈,他卡片上的数字 A 表明了下一个离开的小孩,如果 A 是大于 0 的,则下个离开的是左手边第 A 个,如果是小于 0 的,则是右手边的第 -A 个小孩。游戏将直到所有小孩都离开,在游戏中,第 p 个离开的小孩将得到 F(p) 个糖果,F(p) 是 p 的约数的个数,问谁将得到最多的糖果。输出最幸运的小孩的名字和他可以得到的糖果。

解题思路:建树:节点存的是他所包含的叶结点个数。

                    更新树:用于删除叶结点。

                    反素数:打表。



#include<stdio.h>
#include<string.h>
int antiprime[]={//反素数
	1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,
	20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,
	554400
};

int factor[]={//反素数约数个数
	1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,
	144,160,168,180,192,200,216
};
const int N = 500005 * 4;
int S[N], V[N], L[N], R[N];
void build(int u, int l, int r) {
	L[u] = l;
	R[u] = r;
	S[u] = r - l + 1;
	if (l == r) {
		return;
	}
	int mid = (l + r) / 2;
	build(u * 2, l, mid);
	build(u * 2 + 1, mid + 1, r);
}
int modify(int u, int x) {
	S[u]--;
	if (L[u] == R[u]) {
		return L[u];
	}
	if (S[u * 2] >= x) {
		return modify(u * 2, x);      
	}
	else {
		return modify(u * 2 + 1, x - S[u * 2]);     //如果所查结点不在左子树中,除掉在左子树种的部分,其余的部分在右子树中查找
	}
}
char name[N][50];
int num[N];
int main() {
	int n, k;
	while (scanf("%d%d", &n, &k) == 2) {
		for (int i = 1; i <= n; i++) {
			scanf("%s%d", name[i], &num[i]);
		}
		build(1, 1, n);
		int cnt = 0;
		while (antiprime[cnt] <= n) cnt++;
		cnt--;
		int cnt2 = 0;  
		num[cnt2] = 0;  
		for(int i = 0; i < antiprime[cnt]; i++)  
		{  
			if(num[cnt2] > 0)  
			{  
				k = ((k + num[cnt2] - 2) % S[1] + S[1]) % S[1] + 1;     //"-2“一是因为删除了之前的结点,所以往前移,一是因为要删除本节点,所以向前移
                                                                                                         //第一个() % S[1] 是当num[cnt2]太大时,把它除回来。后面的  +S[1]) % S[1]是考虑负数的情况,最后+1归位  
                         }  
			else  
			{  
				k = ((k + num[cnt2] - 1) % S[1] + S[1]) % S[1] + 1;  
			}  
			cnt2 = modify(1, k);  
		}  
		printf("%s %d\n", name[cnt2], factor[cnt]);  
	}
	return 0 ;
}




poj 2886 Who Gets the Most Candies? (线段树单点更新应用)

标签:c++   poj   

原文地址:http://blog.csdn.net/llx523113241/article/details/42274777

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!