码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1977 Consecutive sum II【水题】

时间:2015-01-01 00:16:08      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:

Consecutive sum II


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2237    Accepted Submission(s): 1093

Problem Description
Consecutive sum come again. Are you ready? Go ~~
1    = 0 + 1
2+3+4    = 1 + 8
5+6+7+8+9  = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.
 
Input
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 2100000).
 
Output
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.
 
Sample Input
3
0
1
2
 
Sample Output
0 1
1 8
8 27
 
Author

Wiskey


题目大意:递推,输入N,输出为N*N*N (N+1)*(N+1)*(N+1)


#include<iostream>
using namespace std;

int main()
{
    __int64 a;
    int T;
    cin >> T;
    while(T--)
    {
        cin >> a;
        cout << a*a*a << " " <<(a+1)*(a+1)*(a+1) << endl;
    }

    return 0;
}


HDU1977 Consecutive sum II【水题】

标签:

原文地址:http://blog.csdn.net/lianai911/article/details/42304393

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!