标签:
Conversions
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1676 Accepted Submission(s): 988
Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:
Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters
and gallons respectively.
Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space
and the unit specification for the converted value.
Sample Input
5
1 kg
2 l
7 lb
3.5 g
0 l
Sample Output
1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g
Source
单位的转化吧,样例包含所有情况了。
上代码
#include <stdio.h>
#include <string.h>
void solve()
{
int t;
int Case=0;
scanf("%d",&t);
while(t--)
{
double m;
char a[155];
scanf("%lf",&m);
scanf("%s",a);
if(strcmp(a,"kg")==0)
printf("%d %.4lf lb\n",++Case,m*2.2046);
if(strcmp(a,"l")==0)
printf("%d %.4lf g\n",++Case,m*0.2642);
if(strcmp(a,"lb")==0)
printf("%d %.4lf kg\n",++Case,m*0.4536);
if(strcmp(a,"g")==0)
printf("%d %.4lf l\n",++Case,m*3.7854);
}
}
int main()
{
solve();
return 0;
}
HDU 1985
标签:
原文地址:http://blog.csdn.net/sky_miange/article/details/42318261