码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 537-Artificial Intelligence?(模拟)

时间:2015-01-02 09:48:45      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:

Artificial Intelligence?
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享


  Artificial Intelligence? 

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don‘t state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There‘s an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don‘t pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn‘t always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept ‘=‘ RealNumber [Prefix] Unit
Concept   ::= ‘P‘ | ‘U‘ | ‘I‘
Prefix    ::= ‘m‘ | ‘k‘ | ‘M‘
Unit      ::= ‘W‘ | ‘V‘ | ‘A‘

Additional assertions:

  • The equal sign (`=‘) will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and UP and I, or U and I will be given.

Output 

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V


题意:根据物理公式P=U*I,给出其中任意两个求另一个。

思路:用的笨办法枚举出了所有的情况,注意单位的换算。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
char str[1010];
int main ()
{
    int T,i,j;
    int k=1;
    double P,I,U,flag;
    while(~scanf("%d",&T))
    {
        getchar();
        while(T--)
        {
            P=U=I=0;
            flag=1;
            gets(str);
            for(i=0; i<strlen(str);)
            {
                if(str[i]=='P'&&str[i+1]=='=')
                {
                    i += 2;
                    while(str[i]>='0'&&str[i]<='9')
                    {
                        P=P*10+str[i]-'0';
                        i++;
                    }
                    if(str[i] == '.')
                    {
                        i++;
                        while(str[i]>='0'&&str[i]<='9')
                        {
                            flag=flag*0.1;
                            P=P+flag*(str[i]-'0');
                            i++;
                        }
                    }
                    flag=1;
                    if(str[i]=='m')
                    {
                        P=P/1000;
                        i++;
                    }
                    else if(str[i]=='k')
                    {
                        P=P*1000;
                        i++;
                    }
                    else if(str[i]=='M')
                    {
                        P=P*1000000;
                        i++;
                    }
                }
                else if(str[i]=='U'&&str[i+1]=='=')
                {
                    i+=2;
                    while(str[i]>='0'&&str[i]<='9')
                    {
                        U=U*10+str[i]-'0';
                        i++;
                    }
                    if(str[i]=='.')
                    {
                        i++;
                        while(str[i]>='0'&&str[i]<='9')
                        {
                            flag=flag*0.1;
                            U=U+flag*(str[i]-'0');
                            i++;
                        }
                    }
                    flag=1;
                    if(str[i]=='m')
                    {
                        U=U/1000;
                        i++;
                    }
                    if(str[i]=='k')
                    {
                        U=U*1000;
                        i++;
                    }
                    else if(str[i]=='M')
                    {
                        U=U*1000000;
                        i++;
                    }
                }
                else if(str[i]=='I'&&str[i+1]=='=')
                {
                    i+=2;
                    while(str[i]>='0'&&str[i]<='9')
                    {
                        I=I*10+str[i]-'0';
                        i++;
                    }
                    if(str[i] == '.')
                    {
                        i++;
                        while(str[i]>='0'&&str[i]<='9')
                        {
                            flag=flag*0.1;
                            I=I+flag*(str[i]-'0');
                            i++;
                        }
                    }
                    flag=1;
                    if(str[i]=='m')
                    {
                        I= I/1000;
                        i++;
                    }
                    if(str[i]=='k')
                    {
                        I=I*1000;
                        i++;
                    }
                    else if(str[i]=='M')
                    {
                        I=I*1000000;
                        i++;
                    }
                }
                i++;
            }
            printf("Problem #%d\n",k++);
            if(P>0&&I>0)
            printf("U=%.2lfV\n",P/I);
            else if(P>0&&U>0)
            printf("I=%.2lfA\n",P/U);
            else if(U>0&&I>0)
            printf("P=%.2lfW\n",U*I);
            printf("\n");
        }
    }
    return 0;
}




UVA 537-Artificial Intelligence?(模拟)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/42323219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!