码迷,mamicode.com
首页 > 其他好文 > 详细

Saruman's Army

时间:2015-01-02 21:02:54      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:

Saruman‘s Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4420   Accepted: 2285

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

 

 

#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define MAX 1001
using namespace std;

int troop[MAX];

void solve(){
    int r, n, res;
    while (cin >> r >> n){
        if (r == -1 && n == -1)return;
        res = 0;
        for (int i = 0; i < n; i++)cin >> troop[i];
        sort(troop, troop + n);
        for (int i = 0, far; i < n;){
            far = troop[i];
            while (i < n&&troop[i] - far <= r)i++;
            res++; //cout << "round:" << res << endl;
            far = troop[i - 1];
            while (i < n&&troop[i] - far <= r)i++;
        }
        cout << res << endl;
    }
}

int main()
{
    solve();
    //system("pause");
    return 0;
}

 

Saruman's Army

标签:

原文地址:http://www.cnblogs.com/littlehoom/p/4198723.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!