码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1170

时间:2015-01-03 09:26:04      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4951    Accepted Submission(s): 1589


 

Problem Description

The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

 


 

Input

Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

 


 

Output

For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

 


 

Sample Input

4+ 1 2- 1 2* 1 2/ 1 2

 


 

Sample Output

3-120.50

 


 

Author

lcy

 

 

 

水题是水题,还是要注意细节,注意读题。坑点,a/b是整数直接输出整数。

The result should be rounded to 2 decimal places If and only if it is not an integer.

 

代码。。

#include <stdio.h>
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		char s[5];
		int a,b;
		double sum;
		scanf("%s%d%d",s,&a,&b);
		if(s[0]=='/')
		{
			if(!(a%b))
			{
				printf("%d\n",a/b);  //如果a除以b是整数,输出整数,
			}
			else
			{
				sum=double(a)*1.0/b;
				printf("%.2lf\n",sum);  //否则保留两位。
			}
		}
		else
		{
			if(s[0]=='+')
				 a+=b;
			if(s[0]=='-')
				 a-=b;
			if(s[0]=='*')
				 a*=b;
			printf("%d\n",a);
		}
	}
	return 0;
}


 

 

HDU 1170

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/42344405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!