码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1102 Constructing Roads【Prim】

时间:2015-01-03 18:39:03      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:

Constructing Roads


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14897    Accepted Submission(s): 5677

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 
Sample Output
179
 
Source

kicc


题目大意:先给你N个村庄之间距离,用矩阵表示。再告诉你S个已经建好的路。

求再建多少距离的路,能实现N个村庄全部联通。

思路:用Prim算法来求最小生成树,已经建好的路就看做是路连接的两个村庄

之间距离为0。图建好后直接用Prim模板就可以了。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int Map[110][110],vis[110],low[110];

void Prim(int N)
{
    memset(vis,0,sizeof(vis));
    int ans = 0;
    vis[1] = 1;
    int pos = 1;
    for(int i = 1; i <= N; ++i)
        if(i != pos)
            low[i] = Map[pos][i];
    for(int i = 1; i < N; ++i)
    {
        int Min = 0xffffff0;
        for(int j = 1; j <= N; ++j)
        {
            if(!vis[j] && low[j] < Min)
            {
                Min = low[j];
                pos = j;
            }
        }
        ans += Min;
        vis[pos] = 1;
        for(int j = 1; j <= N; ++j)
            if(!vis[j] && low[j] > Map[pos][j])
                low[j] = Map[pos][j];
    }
    printf("%d\n",ans);
}
int main()
{
    int N,S,a,b;
    while(cin >> N)
    {
        for(int i = 1; i <= N; ++i)
            for(int j = 1; j <= N; ++j)
                cin >> Map[i][j];
        cin >> S;
        for(int i = 1; i <= S; ++i)
        {
            cin >> a >> b;
            Map[a][b] = Map[b][a] = 0;
        }
        Prim(N);
    }

    return 0;
}


HDU1102 Constructing Roads【Prim】

标签:

原文地址:http://blog.csdn.net/lianai911/article/details/42365623

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!