码迷,mamicode.com
首页 > 其他好文 > 详细

九度OJ 1002 Grading

时间:2015-01-04 01:18:50      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:九度   九度oj   1002   

题目1002:Grading

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:15686

解决:4053

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    ? A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem‘s grade will be the average of G1 and G2.
    ? If the difference exceeds T, the 3rd expert will give G3.
    ? If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem‘s grade will be the average of G3 and the closest grade.
    ? If G3 is within the tolerance with both G1 and G2, then this problem‘s grade will be the maximum of the three grades.
    ? If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int P,T,G1,G2,G3,GJ;
int my_max(int x,int y)
{
    return x>y?x:y;
}
int main(int argc, char *argv[])
{
    while(scanf("%d %d %d %d %d %d",&P,&T,&G1,&G2,&G3,&GJ)!=EOF)
    {
        if(abs(G1-G2)<=T)
            printf("%.1lf\n",(double)(G1+G2)/2.0);
        else if(abs(G1-G3)<=T&&abs(G2-G3)<=T)
            printf("%.1lf\n",my_max(my_max(G1,G2), G3));
        else if(abs(G1-G3)>T&&abs(G2-G3)>T)
            printf("%.1lf\n",(double)GJ);
        else if(abs(G1-G3)<=T&&abs(G2-G3)>T)
            printf("%.1lf\n",((double)(G3+G1))/2.0);
        else if(abs(G2-G3)<=T&&abs(G1-G3)>T)
            printf("%.1lf\n",((double)(G3+G2))/2.0);
    }
    return 0;
}
 
/**************************************************************
    Problem: 1002
    User: kirchhoff
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/




九度OJ 1002 Grading

标签:九度   九度oj   1002   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/42374097

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!