码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2061

时间:2015-01-04 21:30:59      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

Treasure the new start, freshmen!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11218    Accepted Submission(s): 3495


Problem Description
background:
   A new semester comes , and the HDU also meets its 50th birthday. No matter what‘s your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should take the learning attitude just as you have in senior school.
   "No pain, No Gain", HDU also has scholarship, who can win it? That‘s mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA.
   If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is
                 GPA = (C1 * S1 + C2 * S2 +……+Ci * Si……) / (C1 + C2 + ……+ Ci……) (1 <= i <= K, Ci != 0)
   If there is a 0 <= Si < 60, The GPA is always not existed.
 

Input
The first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<= 10), Score(<= 100).
Notice: There is no blank in the Course Name. All the Inputs are legal
 

Output
Output the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases.  
 

Sample Input
2 3 Algorithm 3 97 DataStruct 3 90 softwareProject 4 85 2 Database 4 59 English 4 81
 

Sample Output
90.10 Sorry!
 

Author
zl
 

Source

 

题意,分别相乘求平均值,有小于六十的直接输出Sorry。

略水,因为数组开小了,RE了一次。

上代码。

 

#include <stdio.h>
struct node
{
	double n,score;
	char name[5555];
}
;
node f[5555];
int main()
{
    int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		int flag=0;
		int m;
		double sum=0,sum1=0;
		scanf("%d",&m);
		for(i=1;i<=m;i++)
			scanf("%s%lf%lf",f[i].name,&f[i].n,&f[i].score);
		for(i=1;i<=m;i++)
		{
			if(f[i].score<60)
				flag=1;  //令为一。
			sum+=f[i].n*f[i].score;     //按题目的公式
			sum1+=f[i].n;
		}   
		if(flag)
			printf("Sorry!\n");  //如果真直接sorry
		else
			printf("%.2lf\n",sum*1.0/sum1); // 反之求平均值。
		if(t)
			printf("\n");
	}
	return 0;
}  


 

HDU 2061

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/42396595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!