码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-3487-Play with Chain (Splay tree)

时间:2014-04-27 22:31:19      阅读:295      评论:0      收藏:0      [点我收藏+]

标签:nyoj 558 一二三

一二三

时间限制:1000 ms  |  内存限制:65535 KB
难度:1
描述
    你弟弟刚刚学会写英语的一(one)、二(two)和三(three)。他在纸上写了好些一二三,可惜有些字母写错了。已知每个单词最多有一个字母写错了(单词长度肯定不会错),你能认出他写的啥吗?
输入
第一行为单词的个数(不超过 10)。以下每行为一个单词,单词长度正确,且最多有一个字母写错。所有字母都是小写的。
输出
对于每组测试数据,输出一行,即该单词的阿拉伯数字。输入保证只有一种理解方式。
样例输入
3 
owe 
too 
theee
样例输出
1 
2 
3
AC码:
#include<stdio.h>
#include<string.h>
int main()
{
	int T,len;
	char str[7];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s",str);
		len=strlen(str);
		if(len>3)
			printf("3\n");
		else
		{
			if((str[0]==‘o‘&&str[1]==‘n‘)||(str[0]==‘o‘&&str[2]==‘e‘)||(str[1]==‘n‘&&str[2]==‘e‘))
				printf("1\n");
			else
				printf("2\n");
		}
	}
	return 0;
}


hdu-3487-Play with Chain (Splay tree)

标签:nyoj 558 一二三

原文地址:http://blog.csdn.net/rowanhaoa/article/details/24603033

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!