标签:kmp
Period
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3336 Accepted Submission(s): 1670
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
Recommend
JGShining | We have carefully selected several similar problems for you:
1686 3068 2203 1277 1867
利用 kmp算法的next数组性质,求子串的循环周期
/*************************************************************************
> File Name: hdu1358.cpp
> Author: ALex
> Mail: 405045132@qq.com
> Created Time: 2015年01月05日 星期一 09时15分43秒
************************************************************************/
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1000010;
int next[N];
char str[N];
void get_next()
{
int len = strlen(str);
next[0] = -1;
int j = 0;
int k = -1;
while (j < len)
{
if (k == -1 || str[j] == str[k])
{
next[++j] = ++k;
}
else
{
k = next[k];
}
}
}
int main()
{
int n;
int icase = 1;
while (~scanf("%d", &n), n)
{
scanf("%s", str);
get_next();
printf("Test case #%d\n", icase++);
for (int i = 0; i < n; ++i)
{
if ((i + 1) % (i + 1 - next[i + 1]) == 0)
{
int cnt = (i + 1) / (i + 1 - next[i + 1]);
if (cnt != 1)
{
printf("%d %d\n", i + 1, cnt);
}
}
}
printf("\n");
}
return 0;
}
hdu1358----Period
标签:kmp
原文地址:http://blog.csdn.net/guard_mine/article/details/42419085