标签:des style class blog c code
Highways
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 21039 |
|
Accepted: 9717 |
Description
The island nation of Flatopia is perfectly flat.
Unfortunately, Flatopia has no public highways. So the traffic is difficult in
Flatopia. The Flatopian government is aware of this problem. They‘re planning to
build some highways so that it will be possible to drive between any pair of
towns without leaving the highway system.
Flatopian towns are numbered
from 1 to N. Each highway connects exactly two towns. All highways follow
straight lines. All highways can be used in both directions. Highways can
freely cross each other, but a driver can only switch between highways at a
town that is located at the end of both highways.
The Flatopian
government wants to minimize the length of the longest highway to be built.
However, they want to guarantee that every town is highway-reachable from every
other town.
Input
The first line of input is an integer T, which
tells how many test cases followed.
The first line of each case is an integer
N (3 <= N <= 500), which is the number of villages. Then come N lines,
the i-th of which contains N integers, and the j-th of these N integers is the
distance (the distance should be an integer within [1, 65536]) between village
i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line
contains an integer, which is the length of the longest road to be built such
that all the villages are connected, and this value is minimum.
Sample Input
1
3
0 990 692
990 0 179
692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.
【题目来源】
POJ
Contest,Author:Mathematica@ZSU
【题目大意】
求最小生成树的最大权值。
【题目分析】
Kruskal和prim都能轻松水过。
#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#define MAX 600*300
using namespace std;
struct Node
{
int a,b,c;
};
Node node[MAX];
int parent[MAX];
int num[600][600];
int sum;
int temp;
int Find(int x)
{
return x==parent[x]?x:parent[x]=Find(parent[x]);
}
void Kruskal()
{
int x,y;
int i,j;
for(i=0;i<temp;i++)
{
x=node[i].a;
y=node[i].b;
x=Find(x);
y=Find(y);
if(x!=y)
{
parent[x]=y;
if(sum<node[i].c)
sum=node[i].c;
}
}
}
bool cmp(Node a,Node b)
{
return a.c<b.c;
}
int main()
{
int T,i,j;
cin>>T;
while(T--)
{
sum=0;
for(i=0;i<MAX;i++)
parent[i]=i;
int n;
scanf("%d",&n);
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
scanf("%d",&num[i][j]);
}
}
temp=0;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
node[++temp].a=i;
node[temp].b=j;
node[temp].c=num[i][j];
}
}
sort(node,node+temp,cmp);
Kruskal();
printf("%d\n",sum);
}
return 0;
}
最小生成树 --- 求最大边权,布布扣,bubuko.com
最小生成树 --- 求最大边权
标签:des style class blog c code
原文地址:http://www.cnblogs.com/acmer-jsb/p/3749308.html