码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5137 How Many Maos Does the Guanxi Worth(最短路径)

时间:2015-01-09 10:47:37      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 394    Accepted Submission(s): 120


Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don‘t have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu‘s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu‘s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu‘s plan. All you can do is to persuade ONE person in Boss Liu‘s guanxi net to reject any request. This person can be any one, but can‘t be Boss Liu or the schoolmaster. If you can‘t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu‘s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu‘s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It‘s guaranteed that Boss Liu‘s request can reach the schoolmaster if you do not try to undermine his plan.
 

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

Sample Input
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 

Sample Output
50 Inf
 


题意 : 第一行给你 n 个点 (编号1-n)和 m 个关系。下面 m 行每行输入三

个数 u,v ,val 表示 u 到 v 或 v 到 u 的费用为 val 。默认情况下,总有一条

路可以从1到达n,我们要做的就是去掉一个除了1和n之外的其他任何一个点,

看能不能使得从1不能到达n,如果不能到达,就输出Inf ,如果去掉任何一个

点后都可以使得从1到达n,那么就输出这些最短路径中的最大的最短路径。


思路 : 枚举每个点 (除 1 和 n ),删除该点 , 求 其它 n-1 个点构成的图的

 1 到 n 的最短路径 dis 。若 其中有 dis = inf  则直接输出 Inf ,否则 输出 最大的 dis。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int inf=999999999;
const int maxn=35;

int n,m,dis[maxn][maxn],d[maxn];
bool visited[maxn];

void initial()
{
    for(int i=0; i<maxn; i++)
        for(int j=0; j<maxn; j++)
        {
            if(i==j) dis[i][j]=0;
            else dis[i][j]=inf;
        }
}

void input()
{
    int u,v,val;
    for(int i=0; i<m; i++)
    {
        scanf("%d %d %d",&u,&v,&val);
        dis[u][v]=dis[v][u]=val;
    }
}

int dijkstra(int t)
{
    for(int i=0;i<maxn;i++)   d[i]=inf;
    memset(visited,0,sizeof(visited));
    visited[t]=1;
    d[1]=0;
    while(1)
    {
        int v=-1;
        for(int i=1;i<=n;i++)  if(!visited[i] && (v==-1 || d[i]<d[v]))  v=i;
        if(v==-1)  break;
        visited[v]=true;
        for(int i=1;i<=n;i++)   d[i]=min(d[i],d[v]+dis[v][i]);
    }
    return d[n];
}

void solve()
{
    int ans=-1;
    for(int i=2;i<n;i++)
    {
        int t=dijkstra(i);
        if(t==inf)
        {
            printf("Inf\n");
            return ;
        }
        else ans=max(ans,t);
    }
    printf("%d\n",ans);
}

int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0 && m==0)  break;
        initial();
        input();
        solve();
    }
    return 0;
}


hdu 5137 How Many Maos Does the Guanxi Worth(最短路径)

标签:

原文地址:http://blog.csdn.net/u012596172/article/details/42551205

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!