码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4027----Can you answer these queries?

时间:2015-01-09 21:04:03      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:线段树

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9107    Accepted Submission(s): 2077


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
Case #1: 19 7 6
 

Source
 

Recommend


修改+查询,很明显的线段树题,此题特殊在要对数进行开方,而一个小于2^63的数,最多开6次平方根就变成1,因此我们可以通过判断线段树节点累加值和区间长度比较来判断某个区间是否需要更新,如果要更新,则必须要到叶子节点才能更新


/*************************************************************************
    > File Name: seg_6.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月09日 星期五 16时02分06秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100010;
int data[N][7];

struct node
{
	int l, r;
	long long sum;
}tree[N << 2];


void build (int p, int l, int r)
{
	tree[p].l = l;
	tree[p].r = r;
	if (l == r)
	{
		scanf("%lld", &tree[p].sum);
		return;
	}
	int mid = (l + r) >> 1;
	build (p << 1, l, mid);
	build (p << 1 | 1, mid + 1, r);
	tree[p].sum = tree[p << 1].sum + tree[p << 1 | 1].sum;
}

void update (int p, int l, int r)
{
	if (tree[p].sum == tree[p].r - tree[p].l + 1)
	{
		return;
	}
	if (tree[p].l == tree[p].r)
	{
		tree[p].sum = (long long)(sqrt(tree[p].sum * 1.0));
		return;
	}
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		update (p << 1, l, r);
	}
	else if (l > mid)
	{
		update (p << 1 | 1, l, r);
	}
	else
	{
		update (p << 1, l, mid);
		update (p << 1 | 1, mid + 1, r);
	}
	tree[p].sum = tree[p << 1].sum + tree[p << 1 | 1].sum;
}

long long query (int p, int l, int r)
{
	if (tree[p].l >= l && tree[p].r <= r)
	{
		return tree[p].sum;
	}
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		return query (p << 1, l, r);
	}
	else if (l > mid)
	{
		return query (p << 1 | 1, l, r);
	}
	else
	{
		return query (p << 1, l, mid) + query (p << 1 | 1, mid + 1, r);
	}
}

int main ()
{
	int n, m;
	int icase = 1;
	while (~scanf ("%d", &n))
	{
		int op, x, y;
		build (1, 1, n);
		scanf("%d", &m);
		printf("Case #%d:\n", icase++);
		while (m--)
		{
			scanf("%d%d%d", &op, &x, &y);
			if(x > y)
			{
				swap(x, y);
			}
			if (op)
			{
				printf("%lld\n", query(1, x, y));
			}
			else
			{
				update (1, x, y);
			}
		}
		printf("\n");
	}
	return 0;
}


hdu4027----Can you answer these queries?

标签:线段树

原文地址:http://blog.csdn.net/guard_mine/article/details/42558279

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!