码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1085(Perfect Sequence)

时间:2015-01-09 23:48:11      阅读:495      评论:0      收藏:0      [点我收藏+]

标签:advance pat

Pat1085代码

题目描述:

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

AC代码:
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define MAXN 100005

using namespace std;

double v[MAXN];

int main(int argc,char *argv[]){
	int n;
	double p;
	int i,j;
	scanf("%d%lf",&n,&p);
	for(int i=0;i<n;i++)
		scanf("%lf",&v[i]);
	sort(v,v+n);
	int maxlen=0;
	for(i=0;i<n;i++){
		for(j=i+maxlen-1;j<n;j++){
			double temp=v[i]*p;
			if(v[j]>temp)
				break;
			if(maxlen<j-i+1)
				maxlen=j-i+1;
		}
	}
	printf("%d\n",maxlen);
}

疑惑:题目明明说的n,p和数组元素都是正整数,为什么只有换成double之后最后一个case才能通过,难道测试数据和题目描述不符???

Pat(Advanced Level)Practice--1085(Perfect Sequence)

标签:advance pat

原文地址:http://blog.csdn.net/cstopcoder/article/details/42566243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!