码迷,mamicode.com
首页 > 其他好文 > 详细

ACdream1020:The Game about KILL

时间:2014-05-25 18:19:44      阅读:306      评论:0      收藏:0      [点我收藏+]

标签:acdream      

Problem Description

Teacher HU and his 40 students were trapped by the brigands. To show their power, the head of the brigands want to select one people to kill.
Teacher HU and his 40 students will stand in a circle, and every second person would leave, and the last people in the circle would be killed. For example, if there are 5 persons in the circle, counting proceeds as 2, 4, 1, 5 and person 3 will be killed. To make his students alive, teacher HU calculated the position to be the last man standing, and sacrifice himself.
Now we consider a more common condition, if teacher HU has N - 1 students, which place should he stand to be the last person.

Input

There are multiple test cases.
Each test case only contains an integer N. (1 <= N <= 1,000,000,000)

Output

For each test case, output an integer indicating which place should teacher HU stand.

Sample Input

2
3

Sample Output

1
3

约瑟夫环,n太大,首先可以想到打表找看有没有规律
可以发现时有规律的
可以看到,只要是2的i次幂,那么存活的是1,后面的依次加2
例如4为1,5就是3,6->5,7->7,8->1

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long
ll f[50],n;
 
int main()
{
    int i;
    f[0] = 1;
    for(i = 1; i<31; i++)
        f[i] = f[i-1]*2;
    while(~scanf("%lld",&n))
    {
        for(i = 1; i<31; i++)
        {
            if(n<f[i])
                break;
        }
        printf("%lld\n",1+2*(n-f[i-1]));
    }
 
    return 0;
}


ACdream1020:The Game about KILL,布布扣,bubuko.com

ACdream1020:The Game about KILL

标签:acdream      

原文地址:http://blog.csdn.net/libin56842/article/details/26822809

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!