码迷,mamicode.com
首页 > 其他好文 > 详细

ACdream1012:Convex

时间:2014-05-25 09:50:19      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:acdream   几何   

Problem Description

We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex.

Input

There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contains N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598

简单几何,正弦定理

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
const double pi = acos(-1.0);
 
int main()
{
    int n,i;
    double l,a[50],s;
    while(~scanf("%d%lf",&n,&l))
    {
        for(i = 0;i<n;i++)
        scanf("%lf",&a[i]);
        s = 0;
        for(i = 0;i<n;i++)
        s = s+0.5*l*l*sin(a[i]*pi/180);
        printf("%.3f\n",s);
    }
 
    return 0;
}



ACdream1012:Convex,布布扣,bubuko.com

ACdream1012:Convex

标签:acdream   几何   

原文地址:http://blog.csdn.net/libin56842/article/details/26822279

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!