码迷,mamicode.com
首页 > 其他好文 > 详细

uva 111 History Grading(DP初步应用)

时间:2015-01-13 23:22:43      阅读:513      评论:0      收藏:0      [点我收藏+]

标签:c++   uva   

                  uva 111 History Grading


Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events 技术分享 as 技术分享 where 技术分享 denotes the ranking of event i in the correct chronological order and a sequence of student responses 技术分享 where 技术分享 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with 技术分享 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student‘s chronological ordering of the n events. All lines will contain n numbers in the range 技术分享 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9



题目大意:第一个数n 代表数据中元素的个数, 然后是一个标准答案, 接下来是其他同学的答案, 求出两个序列的最长公共子序列, 注意给出的答案均是以该事件处于第几个发生的, 例如 :2 3 4 1

即是 对应第1个事件在第2个发生,第2个事件在第3个发生 ...转换一下就是  4 1 2 3。


解题思路:

d[i][j] = 

0( i == 0 ||  j == 0)

d[i - 1] [j - 1] + 1 ( a[i] == b[i])

max(d[i - 1][j] , d[i] [j - 1])



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[25], b[25], dp[25][25];
int main() {
	int n, t;
	while (scanf("%d", &n) == 1) {
		for (int i = 1; i <= n; i++) {
			scanf("%d", &t);
			a[t] = i;
		}
		while (scanf("%d", &t) == 1) {
			b[t] = 1;
			for (int i = 2; i <= n; i++) {
				scanf("%d", &t);
				b[t] = i;
			}
			memset(dp, 0, sizeof(dp));
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= n; j++) {
					if (a[i] != b[j]) {
						dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
					}
					else {
						dp[i][j] = dp[i - 1] [j - 1] + 1;
					}
				}
			}
			printf("%d\n", dp[n][n]);
		}
	}
	return 0;
}


uva 111 History Grading(DP初步应用)

标签:c++   uva   

原文地址:http://blog.csdn.net/llx523113241/article/details/42685373

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!