码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2411 Mondriaan's Dream(状压DP)

时间:2015-01-14 23:00:02      阅读:383      评论:0      收藏:0      [点我收藏+]

标签:

Mondriaan‘s Dream
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 12232   Accepted: 7142

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series‘ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 
技术分享

Expert as he was in this material, he saw at a glance that he‘ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won‘t turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

技术分享For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

Source



思路和(前一篇文章)SGU 131 一样,这种类型题目关键就是要学会如何去枚举状态,以及状态的转移。


#include <iostream>
#include <cstring>
#include <cstdio>
#define LL long long
using namespace std;
const int N=12;

LL dp[N][1<<N];
int n,m,len;

void dfs(int x,int y,int s1,int s2,int b1,int b2)
{
    if(y>m)
    {

        if(!b1 && !b2)  dp[x][s1]+=dp[x-1][s2];
        return ;
    }
    if(!b1 && !b2)  dfs(x,y+1,s1*2+1,s2*2,0,0);
    if(!b1)         dfs(x,y+1,s1*2+1,s2*2+1-b2,1,0);
    dfs(x,y+1,s1*2+b1,s2*2+1-b2,0,0);
}

void initial()
{
    len=1<<m;
    memset(dp,0,sizeof(dp));
    dp[0][len-1]=1;
}

void solve()
{
    for(int i=1;i<=n;i++)  dfs(i,1,0,0,0,0);
    printf("%lld\n",dp[n][len-1]);
}

int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(m==0 && n==0)  break;
        initial();
        solve();
    }
    return 0;
}


poj 2411 Mondriaan's Dream(状压DP)

标签:

原文地址:http://blog.csdn.net/u012596172/article/details/42713253

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!