码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5074 Hatsune Miku(简单二维dp)

时间:2015-01-16 20:56:43      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

题目大意:给你一些音符之间的联系,给你一个串,让你求出这个串的最大值。-1的时候可以任意替代,其他情况必须为序列上的数。

解题思路:简单二维dp,分情况处理就可以了啊。

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 637    Accepted Submission(s): 458


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.

技术分享

Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a1, a2, . . . , an, is simply the sum of score(ai, ai+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
270 625
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
#define mod 1000000007

using namespace std;

const int maxn = 110;

int dp[maxn][maxn];
int mp[maxn][maxn];
int num[maxn];

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        int n, m;
        scanf("%d %d",&m, &n);
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++) scanf("%d",&mp[i][j]);
        for(int i = 1; i <= m; i++) scanf("%d",&num[i]);
        memset(dp, 0, sizeof(dp));
        for(int i = 2; i <= m; i++)
        {
            if(num[i-1] == -1)
            {
                if(num[i] == -1)
                {
                    for(int j = 1; j <= n; j++)
                        for(int k = 1; k <= n; k++) dp[i][k] = max(dp[i-1][j]+mp[j][k], dp[i][k]);
                    continue;
                }
                for(int j = 1; j <= n; j++)
                    dp[i][num[i]] = max(dp[i][num[i]], dp[i-1][j]+mp[j][num[i]]);
                continue;
            }
            if(num[i] == -1)
            {
                for(int j = 1; j <= n; j++)
                    dp[i][j] = max(dp[i][j], dp[i-1][num[i-1]]+mp[num[i-1]][j]);
                continue;
            }
            dp[i][num[i]] = dp[i-1][num[i-1]]+mp[num[i-1]][num[i]];
        }
        int Max = 0;
        for(int i = 1; i <= n; i++) Max = max(Max, dp[m][i]);
        cout<<Max<<endl;
    }
    return 0;
}



HDU 5074 Hatsune Miku(简单二维dp)

标签:

原文地址:http://blog.csdn.net/xu12110501127/article/details/42782093

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!