码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2080 夹角有多大II

时间:2015-01-16 23:49:45      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:hdu2080

夹角有多大II

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7676    Accepted Submission(s): 3858


Problem Description
这次xhd面临的问题是这样的:在一个平面内有两个点,求两个点分别和原点的连线的夹角的大小。

注:夹角的范围[0,180],两个点不会在圆心出现。
 

Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有四个实数x1,y1,x2,y2分别表示两个点的坐标,这些实数的范围是[-10000,10000]。
 

Output
对于每组输入数据,输出夹角的大小精确到小数点后两位。
 

Sample Input
2 1 1 2 2 1 1 1 0
 

Sample Output
0.00 45.00
余弦公式:c^2 = a^2 + b^2 - 2abcosy;

#include <stdio.h>
#include <string.h>
#include <math.h>

const double PI = acos(-1.0);

int main() {
	// freopen("stdin.txt", "r", stdin);
	double x1, y1, x2, y2, a, b, c, y;
	int T;
	scanf("%d", &T);
	while (T--) {
		scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
		a = x1 * x1 + y1 * y1;
		b = x2 * x2 + y2 * y2;
		c = (x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2);
		printf("%.2lf\n", acos((a + b - c) / (2 * sqrt(a * b))) * 180.0 / PI);
	}
	return 0;
}


HDU2080 夹角有多大II

标签:hdu2080

原文地址:http://blog.csdn.net/chang_mu/article/details/42788247

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!