码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3974 Assign the task(并查集)

时间:2015-01-17 18:06:01      阅读:370      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody‘s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
Case #1: -1 1 2
 
题意:给你一些属性关系,一但上级被派了某项任务,那么他的所有下属都被
派了这项任务,对于操作(T,X,Y)我们记录此操作节点的被赋予的任务和时间戳。
找某个节点在做什么任务时就找所有上级中最近的时间戳。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int maxn=50000+100;
struct node{
    int val;
    int time;
}e[maxn];
int pre[maxn];
int t,n,m;
int main()
{
    int x,y;
    int cas=1;
    char str[3];
    scanf("%d",&t);
    while(t--)
    {
        CLEAR(pre,-1);
        scanf("%d",&n);
        REPF(i,1,n)
        {
            e[i].val=-1;
            e[i].time=-1;
        }
        REPF(i,1,n-1)
        {
            scanf("%d%d",&x,&y);
            pre[x]=y;
        }
        scanf("%d",&m);
        int T=0;
        printf("Case #%d:\n",cas++);
        while(m--)
        {
            scanf("%s",str);
            if(str[0]=='T')
            {
                scanf("%d%d",&x,&y);
                e[x].val=y;
                e[x].time=++T;
            }
            else
            {
                scanf("%d",&x);
                int val=e[x].val;
                int time=e[x].time;
                while(x!=-1)
                {
                    if(e[x].time>time)
                    {
                        val=e[x].val;
                        time=e[x].time;
                    }
                    x=pre[x];
 //                   cout<<"fuck "<<endl;
                }
                printf("%d\n",val);
            }
        }
    }
    return 0;
}


HDU 3974 Assign the task(并查集)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/42806475

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!