码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ A == B ?

时间:2015-01-17 19:34:11      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:hdoj a b

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 68381    Accepted Submission(s): 10653



Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
1 2 2 2 3 3 4 3
 

Sample Output
NO YES YES NO
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
char str[1000000],s[1000000];
int main()
{
    int l,n,i,j,dot,a,b,c,d,sign,flag;
    while(scanf("%s %s",str,s)!=EOF){
        l=strlen(s);n=strlen(str);
        sign=flag=0;
        if(str[0]=='-')sign=1;
        if(s[0]=='-')flag=1;
        for(i=0;i<n;++i){
            if(str[i]=='-'&&i==0)continue;
            if(str[i]!='0')break;
        }
        for(j=0;j<l;++j){
            if(s[j]=='-'&&j==0)continue;
            if(s[j]!='0')break;
        }
        a=i;b=j;c=n-1;d=l-1;
        if(strchr(str,'.')){
            for(i=n-1;i>=0;--i){
                if(str[i]!='0'){
                    c=i;break;
                }
            }
        }if(str[c]=='.')c--;
        if(strchr(s,'.')){
            for(j=l-1;j>=0;--j)
                if(s[j]!='0'){
                    d=j;break;
                }
        }if(s[d]=='.')d--;
        if(a>b){
            for(i=b;i<=d;++i){
                if(str[i+a-b]!=s[i])break;
            }
            if((i-1)==d&&(i+a-b-1)==c&&sign==flag)printf("YES\n");
            else printf("NO\n");
        }
        else {
            for(j=a;j<=c;++j){
                if(str[j]!=s[j+b-a])break;
            }
            if((j-1)==c&&(j+b-a-1)==d&&sign==flag)printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}
 

HDOJ A == B ?

标签:hdoj a b

原文地址:http://blog.csdn.net/r1986799047/article/details/42807129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!