码迷,mamicode.com
首页 > 其他好文 > 详细

UVA Multiplying by Rotation

时间:2015-01-18 17:13:10      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:

  Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.

Output 

Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.

Sample Input 

10 7 4
9 7 4
17 14 12

Sample Output 

6
2
4



Miguel A. Revilla
1998-03-10



题意:给出3个数据a,b,c,b代表一个十进制的数k(题目未给出,不需要求)的个位数字,然后k*c得到的结果在a进制(例如八进制,十进制,十六进制)下的值p的首位数也是b,要求输出符合k要求的最小位数。


代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int main()
{
    int a,b,c;
    while(cin >> a >> b >> c)
    {
        int count = 0;
        int sum = 0;
        int pb = b;
        int p = 0;
        while(1)
        {
            count++;
            sum = b * c + p;
            b = sum % a;
            p = sum / a;
            if(sum == pb)
            {
                break;
            }
        }
        cout << count << endl;
    }
    return 0;
}

UVA Multiplying by Rotation

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/42836473

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!