码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2056 Rectangles 【矩形面积交】

时间:2015-01-19 10:54:40      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:hdu2056

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15950    Accepted Submission(s): 5104


Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 

Sample Output
1.00 56.25

找出重叠矩形的左下右上坐标,代码有些乱

#include <stdio.h>
#include <math.h>

struct Node {
	double x1, y1, x2, y2;
} p1, p2;

double min(double a, double b) { return a < b ? a : b; }
double max(double a, double b) { return a > b ? a : b; }
void swap(double& a, double& b) { double t = a; a = b; b = t; }

int main() {
	freopen("stdin.txt", "r", stdin);
	double x1, y1, x2, y2;
	while (scanf("%lf%lf%lf%lf%lf%lf%lf%lf", &p1.x1, &p1.y1, &p1.x2, &p1.y2, &p2.x1, &p2.y1, &p2.x2, &p2.y2) != EOF) {
		x1 = min(p1.x1, p1.x2);
		x2 = max(p1.x1, p1.x2);
		y1 = min(p1.y1, p1.y2);
		y2 = max(p1.y1, p1.y2);
		p1.x1 = x1;
		p1.y1 = y1;
		p1.x2 = x2;
		p1.y2 = y2;

		x1 = min(p2.x1, p2.x2);
		x2 = max(p2.x1, p2.x2);
		y1 = min(p2.y1, p2.y2);
		y2 = max(p2.y1, p2.y2);
		p2.x1 = x1;
		p2.y1 = y1;
		p2.x2 = x2;
		p2.y2 = y2;

		x1 = max(p1.x1, p2.x1);	
		y1 = max(p1.y1, p2.y1);	
		x2 = min(p1.x2, p2.x2);	
		y2 = min(p1.y2, p2.y2);	

		printf("%.2lf\n", x1 >= x2 || y1 >= y2 ? 0.0 : (x2 - x1) * (y2 - y1));
	}
	return 0;
}


HDU2056 Rectangles 【矩形面积交】

标签:hdu2056

原文地址:http://blog.csdn.net/chang_mu/article/details/42870109

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!