码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2844 Coins DP

时间:2015-01-19 17:20:31      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:hduj   c++   

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7716    Accepted Submission(s): 3158


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 



#include<iostream>
#include<cstring>
using namespace std;
int dp[100050],c[100050];

int main(){
    int n,m;
    while(cin>>n>>m && (n||m)){
        int i,j;
        int u[105],v[105];
        for(i=0;i<=m;i++)  dp[i]=0;
        for(i=1;i<=n;i++)   cin>>u[i];
        for(i=1;i<=n;i++)   cin>>v[i];

        /*int r=1;
        for(i=1;i<=n;i++){
            for(j=1;j<=v[i];j<<=1){
                c[r++]=j*u[i];
                v[i]-=j;
            }
            if(v[i]>0)  c[r++]=v[i]*u[i];
        }
        for(i=1;i<r;i++)
            for(j=m;j>=[i];j--)
                dp[j]=max(dp[j],dp[j-c[i]]+c[i]);*/
        for(i=1;i<=n;i++){
            for(int k=0;k<=m;k++)   c[k]=0;
            for(j=u[i];j<=m;j++)
            if(dp[j]<dp[j-u[i]]+u[i] && c[j-u[i]]<v[i]){
                dp[j]=dp[j-u[i]]+u[i];
                c[j]=c[j-u[i]]+1;
            }
        }

        int ans=0;
        for(i=1;i<=m;i++)
            if(dp[i]==i)  ans++;
        cout<<ans<<endl;

    }
    return 0;
}


hdu 2844 Coins DP

标签:hduj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/42874525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!