码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2196 Computer DP

时间:2015-01-20 12:06:53      阅读:190      评论:0      收藏:0      [点我收藏+]

标签:hduj   c++   

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3651    Accepted Submission(s): 1852


Problem Description
A school bought the first computer some time ago(so this computer‘s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
技术分享


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
5 1 1 2 1 3 1 1 1
 

Sample Output
3 2 3 4 4


#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<vector>
using namespace std;

typedef long long ll;
#define M 10005

vector<int>  adj[M],wi[M];
ll f[M][2];
int vis[M];

ll dfs1(int u){
    vis[u]=1;
    f[u][0]=0;

    for(int i=0;i<adj[u].size();i++){
        int v=adj[u][i];
        int w=wi[u][i];
        if(vis[v])   continue;

        f[u][0]=max(f[u][0],dfs1(v)+w);
    }
    return f[u][0];
}

void dfs2(int u){
    vis[u]=1;
    int m1=0,m2=0,v1,v2;

    for(int i=0;i<adj[u].size();i++){
        int v=adj[u][i];
        int w=wi[u][i];
        if(vis[v])  continue;

        int tmp=f[v][0]+w;
        if(tmp>m1){
            m2=m1,v2=v1;
            m1=tmp,v1=v;
        }
        else  if(m1==tmp || tmp>m2){
            m2=tmp,v2=v;
        }
    }

    if(u!=1){
        int tmp=f[u][1];
        int v=-1;
        if(tmp>m1){
            m2=m1,v2=v1;
            m1=tmp,v1=v;
        }
        else  if(m1==tmp || tmp>m2){
            m2=tmp,v2=v;
        }
    }

    for(int i=0;i<adj[u].size();i++){
        int v=adj[u][i];
        int w=wi[u][i];
        if(vis[v])  continue;

        if(v==v1)  f[v][1]=m2+w;
        else       f[v][1]=m1+w;
        dfs2(v);
    }
}

int main(){
    int n;
    while(cin>>n && n){
        for(int i=0;i<=n;i++)
            adj[i].clear(),wi[i].clear();
        for(int u=2;u<=n;u++){
            int v,w;
            cin>>v>>w;
            adj[u].push_back(v);
            wi[u].push_back(w);
            adj[v].push_back(u);
            wi[v].push_back(w);
        }

        memset(f,0,sizeof f);
        memset(vis,0,sizeof vis);
        dfs1(1);
        memset(vis,0,sizeof vis);
        dfs2(1);

        for(int j=1;j<=n;j++)
            cout<<max(f[j][0],f[j][1])<<endl;
    }
}













hdu 2196 Computer DP

标签:hduj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/42914533

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!