码迷,mamicode.com
首页 > 其他好文 > 详细

Avoid The Lakes POJ

时间:2015-01-20 20:37:59      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:

Avoid The Lakes
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6409   Accepted: 3466

Description

Farmer John‘s farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

大意:3 4表示矩形框的长和宽,5表示有5个点有水,让你统计连在一起的水最多有多少(3,2),(2,2),(3,1),(2,3),(1,1)

#include<iostream>
#include<algorithm>
using namespace std;
int a[101][101];
int num;
int dfs(int i,int j)
{
    if(a[i][j]==1)
    {
        a[i][j]=-1;
        num++;
        dfs(i+1,j);
        dfs(i-1,j);
        dfs(i,j+1);
        dfs(i,j-1);
    }
   return 0; 
}
int main()
{
    int n,m,k,i,j,x,y,maxn=0;
    while(cin>>n>>m>>k)
    {
        for(i=1;i<=k;i++)
        {
            cin>>x>>y;
            a[x][y]=1;
        } 
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            num=0;
            dfs(i,j);
            if(num>=maxn)
                maxn=num;
        }
        cout<<maxn<<endl;
    }
    return 0;
}


Avoid The Lakes POJ

标签:

原文地址:http://blog.csdn.net/chaoyueziji123/article/details/42921497

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!